Uploaded image for project: 'Puppet'
  1. Puppet
  2. PUP-4602

'bsd' service provider doesn't work with rcng

    Details

    • Type: Bug
    • Status: Closed
    • Priority: Normal
    • Resolution: Fixed
    • Affects Version/s: PUP 4.0.0
    • Fix Version/s: PUP 4.3.0
    • Component/s: Types and Providers
    • Labels:
      None
    • Template:
    • Story Points:
      1
    • Release Notes:
      New Feature
    • Release Notes Summary:
      Previously, puppet could not manage services on NetBSD. This change adds an {{rcng}} service provider, which is the default provider for platforms where the operatingsystem fact returns {{netbsd}} or {{cargos}}.

      Description

      Enabling services with rcng (NetBSD's rc system) doesn't work with the 'bsd' service provider. It writes 'foo_enable="YES"' but that returns an error with rcng.

      A new provider subclassing the 'bsd' provider should be added to fix this.

        Attachments

          Issue Links

            Activity

              People

              • Assignee:
                Unassigned
                Reporter:
                jasper Jasper Lievisse Adriaanse
                QA Contact:
                Eric Thompson
              • Votes:
                0 Vote for this issue
                Watchers:
                1 Start watching this issue

                Dates

                • Created:
                  Updated:
                  Resolved:

                  Zendesk Support