Uploaded image for project: 'Puppet'
  1. Puppet
  2. PUP-4742

Bring semantic_puppet library into Puppet

    Details

    • Type: Task
    • Status: Closed
    • Priority: Normal
    • Resolution: Fixed
    • Affects Version/s: None
    • Fix Version/s: PUP 4.9.0
    • Component/s: None
    • Labels:
      None
    • Template:
    • Team:
      Puppet Developer Experience
    • Story Points:
      1
    • Sprint:
      Language 2016-06-01, Language 2016-06-15, Language 2016-06-29, PDS 2016-11-02, PDS 2016-11-30, PDE 2016-12-14
    • Release Notes:
      Bug Fix
    • Release Notes Summary:
      Hide
      A dependency is added on the semantic_puppet gem >= 0.1.3', '< 2' as this is needed for issues with semantic version comparison functions and types.
      Show
      A dependency is added on the semantic_puppet gem >= 0.1.3', '< 2' as this is needed for issues with semantic version comparison functions and types.
    • QA Risk Assessment:
      No Action
    • QA Risk Assessment Reason:
      internal changes, covered by existing tests

      Description

      Puppet should depend on semantic_puppet instead of the vendored semantic library.

        Attachments

          Issue Links

            Activity

              jsd-sla-details-panel

                People

                • Assignee:
                  Unassigned
                  Reporter:
                  anderson Anderson Mills
                  QA Contact:
                  Eric Thompson
                • Votes:
                  0 Vote for this issue
                  Watchers:
                  9 Start watching this issue

                  Dates

                  • Created:
                    Updated:
                    Resolved:

                    Zendesk Support