Uploaded image for project: 'Puppet'
  1. Puppet
  2. PUP-4747

resource_types response has AST for parameters' default values

    Details

    • Type: Bug
    • Status: Closed
    • Priority: Blocker
    • Resolution: Fixed
    • Affects Version/s: PUP 4.1.0
    • Fix Version/s: PUP 3.8.2, PUP 4.2.0
    • Component/s: None
    • Labels:
    • Template:
    • Story Points:
      1
    • Sprint:
      Language 2015-06-24
    • Release Notes:
      Bug Fix

      Description

      In Puppet 3.x, the resource_types response would contain the unevaluated code assigned to a parameter's default value. For example, if a class were declared as follows:

      class foo($bar=["1", "2"]) {
      }
      

      Then the class's representation in the resource_types response would include:

      "parameters": "[\"1\", \"2\"]"
      

      In Puppet 4.1.0 and above (and probably 4.0.0 as well, though I haven't tested that), the default value is the abstract syntax tree representation rather than the code as written. For the class defined above, the default value in the resource_types response is now:

      "parameters": "([] '1' '2')"
      

        Attachments

          Issue Links

            Activity

              jsd-sla-details-panel

                People

                • Assignee:
                  Unassigned
                  Reporter:
                  dan.lidral-porter Dan Lidral-Porter
                • Votes:
                  0 Vote for this issue
                  Watchers:
                  8 Start watching this issue

                  Dates

                  • Created:
                    Updated:
                    Resolved: