Uploaded image for project: 'Puppet'
  1. Puppet
  2. PUP-4896

puppet parser validate ruby errors

    XMLWordPrintable

    Details

    • Type: Bug
    • Status: Closed
    • Priority: Normal
    • Resolution: Won't Fix
    • Affects Version/s: PUP 3.8.1
    • Fix Version/s: None
    • Component/s: None
    • Labels:
      None
    • Template:

      Description

      I am trying to make my puppet git hook work. I am doing a server side hook, and when i install the pre-receive hook on the git server and while trying to push from my local repo, i get the following error:

      git push
      Counting objects: 11, done.
      Compressing objects: 100% (6/6), done.
      Writing objects: 100% (9/9), 718 bytes, done.
      Total 9 (delta 3), reused 0 (delta 0)
      remote: Checking puppet manifest syntax for site.pp...
      remote: /usr/share/rubygems/rubygems/path_support.rb:68:in `path=': undefined method `+' for nil:NilClass (NoMethodError)
      remote: from /usr/share/rubygems/rubygems/path_support.rb:30:in `initialize'
      remote: from /usr/share/rubygems/rubygems.rb:357:in `new'
      remote: from /usr/share/rubygems/rubygems.rb:357:in `paths'
      remote: from /usr/share/rubygems/rubygems.rb:379:in `path'
      remote: from /usr/share/rubygems/rubygems/specification.rb:794:in `dirs'
      remote: from /usr/share/rubygems/rubygems/specification.rb:658:in `each_normal'
      remote: from /usr/share/rubygems/rubygems/specification.rb:669:in `_all'
      remote: from /usr/share/rubygems/rubygems/specification.rb:822:in `each'
      remote: from /usr/share/rubygems/rubygems/specification.rb:864:in `find'
      remote: from /usr/share/rubygems/rubygems/specification.rb:864:in `find_inactive_by_path'
      remote: from /usr/share/rubygems/rubygems.rb:175:in `try_activate'
      remote: from /usr/share/rubygems/rubygems/core_ext/kernel_require.rb:132:in `rescue in require'
      remote: from /usr/share/rubygems/rubygems/core_ext/kernel_require.rb:144:in `require'
      remote: from <internal:abrt_prelude>:2:in `<compiled>'
      remote: Error: puppet syntax error in site.pp (see above)
      remote: Error: 1 syntax error(s) found in puppet manifests. Commit will be aborted.
      remote: puppet-lint not installed. Skipping puppet-lint tests...
      remote: Error: 1 subhooks failed. Declining push.

        Attachments

          Activity

            People

            Assignee:
            anirudh Anirudh Srinivasan
            Reporter:
            anirudh Anirudh Srinivasan
            Votes:
            0 Vote for this issue
            Watchers:
            3 Start watching this issue

              Dates

              Created:
              Updated:
              Resolved:

                Zendesk Support