Uploaded image for project: 'Puppet'
  1. Puppet
  2. PUP-4955

Puppet 3.x ci:test:git pre-suite has implicit dependency on EPEL

    XMLWordPrintable

    Details

    • Type: Bug
    • Status: Closed
    • Priority: Normal
    • Resolution: Won't Fix
    • Affects Version/s: PUP 3.8.1
    • Fix Version/s: None
    • Component/s: None
    • Labels:
      None
    • Template:
    • Story Points:
      1

      Description

      The Puppet 3.x ci:test:git pre-suite has an implicit dependency on EPEL for rubygem-json. This causes an error trying to run 3.x's ci:test:git rake task on a Centos 5 or 6 machine (maybe others).

      Any solution to this should be done in Puppet pre-suite. We could either enable EPEL, setup the puppetlabs-dep repo before loading package dependencies, or find some way around needing rubygem-json. I vote for loading puppetlabs-dep if that doesn't interfere with testing.

        Attachments

          Activity

            People

            Assignee:
            eric.sorenson Eric Sorenson
            Reporter:
            michael.smith Michael Smith
            Votes:
            0 Vote for this issue
            Watchers:
            2 Start watching this issue

              Dates

              Created:
              Updated:
              Resolved:

                Zendesk Support