Uploaded image for project: 'Puppet'
  1. Puppet
  2. PUP-4970

puppetlabs-release and puppetlabs-release-pc1 both needed but fails on RHEL6

    Details

    • Type: Bug
    • Status: Closed
    • Priority: Blocker
    • Resolution: Duplicate
    • Affects Version/s: PUP 4.2.1
    • Fix Version/s: None
    • Component/s: None
    • Labels:
      None
    • Environment:

      Centos 6, RHEL 6

    • Template:

      Description

      I want to both install puppet 4 and some mcollective plugins on a CentOS 6

      As the the mcollective plugins are not in the PC1 repository, I need the products repository. But then :

      yum install https://yum.puppetlabs.com/el/6/products/x86_64/puppetlabs-release-6-11.noarch.rpm https://yum.puppetlabs.com/el/6/PC1/x86_64/puppetlabs-release-pc1-0.9.2-1.el6.noarch.rpm
      ...
      Transaction Check Error:
       file /etc/pki/rpm-gpg/RPM-GPG-KEY-puppetlabs conflicts between attempted installs of puppetlabs-release-pc1-0.9.2-1.el6.noarch and puppetlabs-release-6-11.noarch
      

      That's a brand new installation.
      On a CentOS 7:

      yum install https://yum.puppetlabs.com/el/7/PC1/x86_64/puppetlabs-release-pc1-0.9.2-1.el7.noarch.rpm https://yum.puppetlabs.com/el/7/products/x86_64/puppetlabs-release-7-11.noarch.rpm
      ...
      Installed:
       puppetlabs-release.noarch 0:7-11                                                             puppetlabs-release-pc1.noarch 0:0.9.2-1.el7                                                            
       
      Complete!
      

      Is there a bug in Centos6 packaging ?

      Do you intent to move the mcollective rpm to pc1 or allow both to be installed ?

        Attachments

          Issue Links

            Activity

              People

              • Assignee:
                matthaus Past Haus
                Reporter:
                fbacchella Fabrice Bacchella
              • Votes:
                2 Vote for this issue
                Watchers:
                6 Start watching this issue

                Dates

                • Created:
                  Updated:
                  Resolved:

                  Zendesk Support