Uploaded image for project: 'Puppet'
  1. Puppet
  2. PUP-530

Installer for Puppet 3 does not check for hiera

    Details

    • Type: Bug
    • Status: Closed
    • Priority: Normal
    • Resolution: Fixed
    • Affects Version/s: PUP 3.3.1
    • Fix Version/s: PUP 3.6.0
    • Component/s: None
    • Labels:
      None
    • Template:

      Description

      The `install.rb` script for puppet checks for facter and will refuse to install puppet if facter is not on the system. However, puppet also cannot function correctly without hiera and the `install.rb` script does not check for that.

      The installation script that we ship in the tarball should also check for hiera being present.

        Attachments

          Issue Links

            Activity

              jsd-sla-details-panel

                People

                • Assignee:
                  moses Moses Mendoza
                  Reporter:
                  andy Andrew Parker
                • Votes:
                  0 Vote for this issue
                  Watchers:
                  2 Start watching this issue

                  Dates

                  • Created:
                    Updated:
                    Resolved:

                    Zendesk Support