Uploaded image for project: 'Puppet'
  1. Puppet
  2. PUP-5357

PMT - Allow Installation of Latest Pre-release Modules

    Details

    • Type: New Feature
    • Status: Closed
    • Priority: Normal
    • Resolution: Won't Fix
    • Affects Version/s: None
    • Fix Version/s: None
    • Component/s: PMT
    • Labels:
    • Template:

      Description

      Currently the PMT will install the latest semver module from the Forge. (x.y.z) However, if you want to install the latest version of a pre-release (x.y.z-alpha) you have to explicitly pass in the version to PMT. It would be nice if there was a new command-line option "--pre-release" that would change the PMT behavior to instead the latest pre-release version of the module. This is specifically for installing from the module staging Forge for acceptance testing.

        Attachments

          Issue Links

            Activity

              jsd-sla-details-panel

                People

                • Assignee:
                  anderson Anderson Mills
                  Reporter:
                  ryan.gard Ryan Gard
                • Votes:
                  0 Vote for this issue
                  Watchers:
                  4 Start watching this issue

                  Dates

                  • Created:
                    Updated:
                    Resolved:

                    Zendesk Support