Uploaded image for project: 'Puppet'
  1. Puppet
  2. PUP-5453

Yum package provider: ensure => latest fails when security packages are present

    XMLWordPrintable

    Details

    • Type: Bug
    • Status: Closed
    • Priority: Normal
    • Resolution: Duplicate
    • Affects Version/s: PUP 4.2.2
    • Fix Version/s: None
    • Component/s: Types and Providers
    • Labels:
      None
    • Template:

      Description

      When the yum provider has packages marked as security, the yum provider fails to ensure => latest on a package. This is almost like https://tickets.puppetlabs.com/browse/PUP-4497 and this fix should be almost the same.

      Output of `yum check-update` ends with:
      ```
      Security: kernel-3.10.0-229.14.1.el7.x86_64 is an installed security update
      Security: kernel-3.10.0-229.4.2.el7.x86_64 is the currently running version
      ```

        Attachments

          Issue Links

            Activity

              People

              Assignee:
              kylo Kylo Ginsberg
              Reporter:
              mcanevet Mickaël Canévet
              Votes:
              0 Vote for this issue
              Watchers:
              2 Start watching this issue

                Dates

                Created:
                Updated:
                Resolved:

                  Zendesk Support