Uploaded image for project: 'Puppet'
  1. Puppet
  2. PUP-5545

Use rubocop in module generator

    Details

    • Type: Bug
    • Status: Closed
    • Priority: Normal
    • Resolution: Fixed
    • Affects Version/s: None
    • Fix Version/s: PUP 4.5.0
    • Component/s: PMT
    • Labels:
    • Template:
    • Story Points:
      1
    • Sprint:
      Client 2016-05-04, Client 2016-05-18

      Description

      This is meant to enforce consistent style with ruby code and spec tests. Rubocop itself requires ruby >= 1.9.3. We still want to support ruby 1.8.7 and Puppet 3 and this code takes that into consideration.

        Attachments

          Activity

            jsd-sla-details-panel

              People

              • Assignee:
                Unassigned
                Reporter:
                ghoneycutt garrett honeycutt
                QA Contact:
                Eric Thompson
              • Votes:
                0 Vote for this issue
                Watchers:
                3 Start watching this issue

                Dates

                • Created:
                  Updated:
                  Resolved: