Details

    • Type: New Feature
    • Status: Closed
    • Priority: Normal
    • Resolution: Fixed
    • Affects Version/s: None
    • Fix Version/s: PUP 4.4.0
    • Component/s: None
    • Labels:
    • Release Notes:
      New Feature
    • Release Notes Summary:
      This adds initial Ruby 2.3 support. However, note that using puppet with ruby 2.3.0 is not recommended yet.

      Description

      Ruby 2.3 will be released Dec 25 2015, so we should add support. To be clear, bumping puppet-agent to include ruby 2.3 is not planned at all. This ticket is just to enable specs to pass with ruby 2.3 and to enable it in travis ci.

        Attachments

          Issue Links

            Activity

              jsd-sla-details-panel

                People

                • Assignee:
                  Unassigned
                  Reporter:
                  kylo Kylo Ginsberg
                • Votes:
                  0 Vote for this issue
                  Watchers:
                  1 Start watching this issue

                  Dates

                  • Created:
                    Updated:
                    Resolved: