Uploaded image for project: 'Puppet'
  1. Puppet
  2. PUP-5688

puppet module tool needs to respect metadata version constraint

    Details

    • Type: Improvement
    • Status: Needs Information
    • Priority: Normal
    • Resolution: Unresolved
    • Affects Version/s: None
    • Fix Version/s: None
    • Component/s: PMT
    • Labels:
      None
    • Template:
    • Team:
      Puppet Developer Experience

      Description

      In order to facilitate people moving to Puppet 4 only versions of their module the Puppet Module Tool should learn to respect the Puppet version constraint in metadata.json. If a module is to be installed on a Puppet 3.8 system (without future parser enabled) it should default to installing the latest version that is Puppet 3 compatible, not just the latest.

        Attachments

          Issue Links

            Activity

              jsd-sla-details-panel

                People

                • Assignee:
                  Unassigned
                  Reporter:
                  daenney Daniele Sluijters
                • Votes:
                  0 Vote for this issue
                  Watchers:
                  4 Start watching this issue

                  Dates

                  • Created:
                    Updated:

                    Zendesk Support