Uploaded image for project: 'Puppet'
  1. Puppet
  2. PUP-5689

puppet module tool to support passing in a version

    XMLWordPrintable

Details

    • Improvement
    • Status: Closed
    • Normal
    • Resolution: Won't Fix
    • None
    • None
    • None
    • None
    • Platform Core

    Description

      In order to help people running in a mixed Puppet environment (with modern masters but perhaps older agents) it should be possible to explicitly tell PMT which version of a module to install. This will allow the administrator to install a specific, Puppet 3 compatible, module version even though it might satisfy the version constraint according to metadata.json that would otherwise cause it to install a Puppet 4 only compatible version.

      Attachments

        Issue Links

          Activity

            People

              Unassigned Unassigned
              daenney Daniele Sluijters
              Votes:
              0 Vote for this issue
              Watchers:
              4 Start watching this issue

              Dates

                Created:
                Updated:
                Resolved:

                Zendesk Support