Uploaded image for project: 'Puppet'
  1. Puppet
  2. PUP-5823

Puppet agent with splay on windows begets random interval between runs

    Details

    • Type: Bug
    • Status: Accepted
    • Priority: Normal
    • Resolution: Unresolved
    • Affects Version/s: None
    • Fix Version/s: None
    • Component/s: None
    • Template:
    • Team:
      Platform OS

      Description

      Further to the thread at https://groups.google.com/forum/?fromgroups#!searchin/puppet-users/splay/puppet-users/56pWWnUslR8/C7iO-nmeCQAJ I'm finally getting round to logging this as an issue:

      We are running puppet (3.7.x) on Windows daemonized. We recently turned on splay because reasons. After having done so the interval between daemonised runs, counter to expectation, has become randomised (though we get an averageish run interval of 30 minutes (30.5 recurring)). The linuxes here have identical config and their runs are as regular as a muesli eating vegetarian. Here are some report times and approximate delta of a representative Windows 2012:
      Oct 21 2015 - 16:03:27 (14)
      Oct 21 2015 - 15:49:10 (28)
      Oct 21 2015 - 15:21:14 (33)
      Oct 21 2015 - 14:48:23 (32)
      Oct 21 2015 - 14:16:47 (23)
      Oct 21 2015 - 13:53:35 (36)
      Oct 21 2015 - 13:17:57 (27)
      Oct 21 2015 - 12:54:02 (29)
      Oct 21 2015 - 12:25:20 (53)
      Oct 21 2015 - 11:31:48

        Attachments

          Activity

            jsd-sla-details-panel

              People

              • Assignee:
                Unassigned
                Reporter:
                fiddyspence Chris Spence
              • Votes:
                1 Vote for this issue
                Watchers:
                7 Start watching this issue

                Dates

                • Created:
                  Updated: