Uploaded image for project: 'Puppet'
  1. Puppet
  2. PUP-5954

Change deprecation from PUP-2695 (merge class) to error

    XMLWordPrintable

    Details

    • Type: Bug
    • Status: Closed
    • Priority: Normal
    • Resolution: Fixed
    • Affects Version/s: None
    • Fix Version/s: PUP 5.0.0
    • Component/s: Compiler
    • Labels:
      None
    • Template:
    • Epic Link:
    • Team:
      Puppet Developer Experience
    • Story Points:
      1
    • Sprint:
      PDE 2017-01-25, PDE 2017-02-08
    • Release Notes:
      Deprecation
    • Release Notes Summary:
      Hide
      Before this, if a class was defined more than once their bodies would be merged. The output of a warning or error was under the control of the --strict flag.
      Now, this is always an error except for the top scope class named '' (a.k.a 'main').
      Show
      Before this, if a class was defined more than once their bodies would be merged. The output of a warning or error was under the control of the --strict flag. Now, this is always an error except for the top scope class named '' (a.k.a 'main').
    • QA Risk Assessment:
      No Action
    • QA Risk Assessment Reason:
      deprecation, covered by unit tests

      Attachments

        Issue Links

          Activity

            People

            Assignee:
            Unassigned
            Reporter:
            henrik.lindberg Henrik Lindberg
            Votes:
            0 Vote for this issue
            Watchers:
            2 Start watching this issue

              Dates

              Created:
              Updated:
              Resolved:

                Zendesk Support