Uploaded image for project: 'Puppet'
  1. Puppet
  2. PUP-6007

Irrelevant message when a module upgrade fails for reasons of unsatisfied dependencies versions


    • Type: Improvement
    • Status: Closed
    • Priority: Normal
    • Resolution: Won't Fix
    • Affects Version/s: PUP 4.3.2
    • Fix Version/s: None
    • Component/s: PMT
    • Labels:
    • Environment:

      Ubuntu Trusty
      package puppet-agent 1.3.5-1trusty
      package puppetserver 2.2.1-1puppetlabs1


      I have several modules installed but only one depends on the module arioch-keepalived (it's just an example, this particular module doesn't matter here):

      ~# cd /etc/puppetlabs/code/environments/production/
      ~# grep -R --color arioch-keepalived modules/
      modules/keepalived/metadata.json:  "name": "arioch-keepalived",
      modules/keepalived_vip/metadata.json:    {"name":"arioch-keepalived","version_requirement":"1.2.0"}

      As you can see, just one module depends on the module arioch-keepalived: it's the module keepalived_vip and it requires the module arioch-keepalived version 1.2.0 exactly.

      Now, I try to upgrade the module arioch-keepalived:

      ~# puppet module upgrade arioch-keepalived --ignore-changes
      Notice: Preparing to upgrade 'arioch-keepalived' ...
      Notice: Found 'arioch-keepalived' (v1.2.0) in /etc/puppetlabs/code/environments/production/modules ...
      Notice: Downloading from https://forgeapi.puppetlabs.com ...
      Error: Could not upgrade module 'arioch-keepalived' (v1.2.0 -> latest)
        There are 3 newer versions
          No combination of dependency upgrades would satisfy all dependencies
          Dependencies will not be automatically upgraded across major versions
          Upgrading one or more of these modules may permit the upgrade to succeed:
          - puppetlabs-stdlib
          - puppetlabs-concat
          Use `puppet module upgrade --force` to upgrade only this module

      It's normal that the upgrade fails because the module keepalived_vip requires the module arioch-keepalived version 1.2.0 exactly (good!) but the message is completely irrelevant because it talks about the modules puppetlabs-stdlib and puppetlabs-concat which don't depend on arioch-keepalived at all. The real reason which explains why the upgrade is not possible is not given.





              • Assignee:
                anderson Anderson Mills
                flaf Francois Lafont
              • Votes:
                0 Vote for this issue
                3 Start watching this issue


                • Created:

                  Zendesk Support