Uploaded image for project: 'Puppet'
  1. Puppet
  2. PUP-6079

The windows puppetagent version available for download in " https://puppetlabs.com/download-puppet-enterprise-get-expand " is more than the puppet master version available in the same link

    XMLWordPrintable

    Details

    • Type: Bug
    • Status: Closed
    • Priority: Normal
    • Resolution: Won't Fix
    • Affects Version/s: PUP 3.8.6, PUP 4.3.2
    • Fix Version/s: None
    • Component/s: Windows
    • Labels:
      None
    • Template:

      Description

      I have a issue in working with windows puppet agent .

      I have used "https://puppetlabs.com/download-puppet-enterprise-get-expand" (64 bit) to download the Windows puppet agent (Windows Server 2012 R2) in my virtual machine. The machine is downloaded with version 4.3.2 as below

      C:\ProgramData\PuppetLabs\puppet\etc\ssl\public_keys> puppet -V
      4.3.2

      On the same Vnet I have my puppet master Ubuntu machine(Ubuntu Server 15.10) to which I have downloaded puppet master from same URL as mentioned above but from the Master tab.

      But when I tried to communicate with Puppet Master server from agent and Cert exchange from Puppet master to puppet agent, puppet agent is throwing me an error which stated environment should be alphanumeric as below.

      C:\Users\Sampada>puppet agent -t
      Error: Could not request certificate: Error 400 on SERVER: The environment must
      be purely alphanumeric, not 'puppet-ca'
      Exiting; failed to retrieve certificate and waitforcert is disabled

      Can you please let me know how this can be resolved?
      Can the masters version can be lower than its puppet agents?
      How can I upgrade my puppet master / lower the version of my puppet agent as there is no option to select the version in the mentioned links?

        Attachments

          Activity

            People

            Assignee:
            Unassigned Unassigned
            Reporter:
            Jainsam Sampada Jain
            Votes:
            0 Vote for this issue
            Watchers:
            2 Start watching this issue

              Dates

              Created:
              Updated:
              Resolved:

                Zendesk Support