Uploaded image for project: 'Puppet'
  1. Puppet
  2. PUP-6237

PMT should gracefully fall back to older, compatible versions of modules

    Details

    • Type: Improvement
    • Status: Accepted
    • Priority: Normal
    • Resolution: Unresolved
    • Affects Version/s: None
    • Fix Version/s: None
    • Component/s: PMT
    • Labels:
      None
    • Template:
    • Team:
      Puppet Developer Experience

      Description

      I coulda sworn there was a ticket to this effect but I've been searching for 20 mins to no avail, so I'll just file a new one.

      Currently when you want to puppet module install a module which expresses compatibility with a newer Puppet version than yours, you get an error and a hard failure. Instead, the module should select the latest version of the module which is compatible with your version of Puppet and install that.

      This would make it much easier for module authors to maintain independent major-versions of their modules to match capabilities available in different versions of Puppet, while providing a nice user experience.

        Attachments

          Activity

            jsd-sla-details-panel

              People

              • Assignee:
                Unassigned
                Reporter:
                eric.sorenson Eric Sorenson
              • Votes:
                0 Vote for this issue
                Watchers:
                2 Start watching this issue

                Dates

                • Created:
                  Updated:

                  Zendesk Support