Uploaded image for project: 'Puppet'
  1. Puppet
  2. PUP-6244

Acceptance: fix module upgrade tests

    Details

    • Type: Task
    • Status: Closed
    • Priority: Normal
    • Resolution: Fixed
    • Affects Version/s: PUP 4.4.2
    • Fix Version/s: PUP 4.9.0
    • Component/s: None
    • Labels:
    • Template:
    • Team:
      Puppet Developer Experience
    • Story Points:
      1
    • Sprint:
      PDS 2016-11-30
    • Release Notes:
      Not Needed

      Description

      The following module upgrade acceptance tests are being skipped because they attempt to set the modulepath via puppet.conf which is no longer supported. These tests should be fixed and unskipped.

      • tests/modules/upgrade/that_was_installed_twice.rb
      • tests/modules/upgrade/with_scattered_dependencies.rb

        Attachments

          Issue Links

            Activity

              People

              • Assignee:
                whopper William Hopper
                Reporter:
                john.duarte John Duarte
              • Votes:
                0 Vote for this issue
                Watchers:
                2 Start watching this issue

                Dates

                • Created:
                  Updated:
                  Resolved:

                  Zendesk Support