Uploaded image for project: 'Puppet'
  1. Puppet
  2. PUP-6551

Pin json_pure dependency to < 2

    XMLWordPrintable

    Details

    • Type: Task
    • Status: Closed
    • Priority: Blocker
    • Resolution: Fixed
    • Affects Version/s: None
    • Fix Version/s: PUP 3.8.8, PUP 4.5.4, PUP 4.6.0
    • Component/s: None
    • Labels:
      None
    • Template:
    • Story Points:
      1
    • Sprint:
      Windows 2016-07-27, Windows 2016-08-10
    • Release Notes:
      Not Needed

      Description

      json_pure as of 2.0.2 requires Ruby 2 - because Puppet and associates test against many different versions of ruby, including 1.9.3, we may need to ensure we can still get json_pure without conflicts.
      This snipped is going into modules:

      gem 'json_pure', '<=2.0.1', :require => false if RUBY_VERSION =~ /^1\./
      

        Attachments

          Issue Links

            Activity

              People

              Assignee:
              ethan Ethan Brown
              Reporter:
              moses Moses Mendoza
              Votes:
              0 Vote for this issue
              Watchers:
              2 Start watching this issue

                Dates

                Created:
                Updated:
                Resolved:

                  Zendesk Support