Uploaded image for project: 'Puppet'
  1. Puppet
  2. PUP-6701

PE Everett fails to install: Unknown function: 'puppetdb_query'

    Details

    • Type: CI Blocker
    • Status: Closed
    • Priority: Normal
    • Resolution: Fixed
    • Affects Version/s: PUP 4.8.0
    • Fix Version/s: PUP 4.8.0
    • Component/s: None
    • Labels:
      None
    • CI Pipeline/s:
      pe-integration pe-2016.5.x
    • Team:
      Puppet Developer Experience
    • Story Points:
      1
    • Sprint:
      PDS 2016-09-21, PDS 2016-10-05
    • Release Notes:
      Not Needed
    • Release Notes Summary:
      Bug introduced before release.

      Description

      The install of PE 2016.5.x are failing pretty quick with:

      2016-09-13 15:15:06,868 Running command: /opt/puppetlabs/puppet/bin/puppet enterprise configure  --detailed-exitcodes --modulepath /opt/puppetlabs/server/data/enterprise/modules
      2016-09-13 15:15:08,925 - [Warning]: Undefined variable 'pe_server_version';
         (file & line not available)
      2016-09-13 15:15:08,925 - [Warning]: Undefined variable 'pe_version';
         (file & line not available)
      2016-09-13 15:15:10,367 - [Error]: Evaluation Error: Unknown function: 'puppetdb_query'. at /opt/puppetlabs/server/data/enterprise/modules/puppet_enterprise/manifests/cli_config.pp:76:13 on node s8sw6jn6rzea26o.delivery.puppetlabs.net
      

      The only change from the previous green smoke build has been puppet-agent 1.6.2-166.

        Attachments

          Activity

            jsd-sla-details-panel

              People

              • Assignee:
                Unassigned
                Reporter:
                christopher.thorn Christopher Thorn
              • Votes:
                0 Vote for this issue
                Watchers:
                4 Start watching this issue

                Dates

                • Created:
                  Updated:
                  Resolved:

                  Zendesk Support