Uploaded image for project: 'Puppet'
  1. Puppet
  2. PUP-6760

Solaris pkg provider does not correctly handle expiring cert

    XMLWordPrintable

    Details

    • Template:
    • Team:
      Night's Watch

      Description

      The pkg provider is failing with the following when a certificate is near expiration:

      Error: /Stage[main]/Puppet_agent::Install/Package[puppet-agent]/ensure: change from 1.5.3,5.11-1:20160720T002950Z to 1.6.2.163.938 failed: Unknown line format pkg: Certificate '/var/pkg/ssl/afdb2b56593e6ede1a777795c11354c467b3b4cb' for publisher 'solarisstudio', needed to access 'https://pkg.oracle.com/solarisstudio/release/', will expire in '26' days.
      

      We want to be able to report output like this instead of pulling it into an error.

        Attachments

          Issue Links

            Activity

              People

              Assignee:
              Unassigned
              Reporter:
              branan Branan Riley
              Votes:
              0 Vote for this issue
              Watchers:
              2 Start watching this issue

                Dates

                Created:
                Updated:

                  Zendesk Support