Uploaded image for project: 'Puppet'
  1. Puppet
  2. PUP-6777

regression: incompatible character encodings: UTF-8 and ASCII-8BIT

    Details

    • Type: Bug
    • Status: Closed
    • Priority: Normal
    • Resolution: Fixed
    • Affects Version/s: PUP 4.6.1
    • Fix Version/s: PUP 4.9.0
    • Component/s: None
    • Labels:
    • Release Notes:
      Bug Fix
    • Release Notes Summary:
      Same as PUP-7031.
    • QA Risk Assessment:
      Automate
    • QA Risk Assessment Reason:
      Regression

      Description

      This bug - seemingly fixed in https://github.com/puppetlabs/puppet/pull/3977#issuecomment-251466761 seems to have cropped up again:
      https://bugs.debian.org/cgi-bin/bugreport.cgi?bug=782494

      This bug has cropped up again in puppet-4.6.1 (puppet-agent 1.6.1) - since we upgraded from puppet-3.7.1 on an agent. it only happens when we run puppet in cron - and the workaround LANG=en_US.utf8 in front of puppet agent -t - works.

        Attachments

          Issue Links

            Activity

              jsd-sla-details-panel

                People

                • Assignee:
                  moses Moses Mendoza
                  Reporter:
                  KlavsKlavsen Klavs Klavsen
                • Votes:
                  1 Vote for this issue
                  Watchers:
                  7 Start watching this issue

                  Dates

                  • Created:
                    Updated:
                    Resolved: