Details

    • Type: Sub-task
    • Status: Resolved
    • Priority: Normal
    • Resolution: Fixed
    • Affects Version/s: None
    • Fix Version/s: None
    • Component/s: None
    • Labels:
      None
    • Template:
    • Team:
      Puppet Developer Experience
    • Sprint:
      SE 2016-09-21, PDE 2017-01-11, PDE 2017-01-25, PDE 2017-02-08
    • QA Risk Assessment:
      Automate

      Description

      Puppet is introducing a dependency on the hocon gem. This will require that the puppet-agent package is only installable on a new enough version of the puppet-server (which will include the gem).

      Tests should be written to validate that the puppet-agent will not install with an incorrrect puppet-server version, and that the functionality that depends on the gem functions correctly when run in a puppet-server context.

        Attachments

          Issue Links

            Activity

              jsd-sla-details-panel

                People

                • Assignee:
                  Unassigned
                  Reporter:
                  branan Branan Riley
                • Votes:
                  0 Vote for this issue
                  Watchers:
                  5 Start watching this issue

                  Dates

                  • Created:
                    Updated:
                    Resolved:

                    Zendesk Support