Uploaded image for project: 'Puppet'
  1. Puppet
  2. PUP-6942

Modify lookup to always use hiera.yaml.

    Details

    • Type: Improvement
    • Status: Closed
    • Priority: Normal
    • Resolution: Fixed
    • Affects Version/s: None
    • Fix Version/s: PUP 4.9.0
    • Component/s: None
    • Labels:
      None
    • Template:
    • Team:
      Puppet Developer Experience
    • Story Points:
      2
    • Sprint:
      PDS 2016-11-30, PDE 2016-12-14
    • Release Notes:
      New Feature
    • Release Notes Summary:
      This change allows the use of {{hiera.yaml}} to configure data lookups in modules and environments in hiera v5. We also deprecate older uses and warn on conflicting configurations.
    • QA Risk Assessment:
      No Action
    • QA Risk Assessment Reason:
      warnings and deprecations; covered well by unit tests. hiera.yaml usage covered in acceptance elsewhere

      Description

      The new configuration file lookup.yaml that was introduced in PUP-6511 and PUP-6780 as a replacement for hiera.yaml has been subject to some discussion and a new decision was made revert that and instead retain the hiera.yaml file and just check its version. If the verison is >= 5, then it will act according to the specification that was intended for lookup.yaml.

        Attachments

          Activity

            People

            • Assignee:
              Unassigned
              Reporter:
              thomas.hallgren Thomas Hallgren
              QA Contact:
              Eric Thompson
            • Votes:
              1 Vote for this issue
              Watchers:
              4 Start watching this issue

              Dates

              • Created:
                Updated:
                Resolved:

                Zendesk Support