Uploaded image for project: 'Puppet'
  1. Puppet
  2. PUP-6990

Unable to specify RPM with architecture in tag

    XMLWordPrintable

    Details

    • Type: Bug
    • Status: Accepted
    • Priority: Normal
    • Resolution: Unresolved
    • Affects Version/s: PUP 4.5.0, PUP 4.5.1, PUP 4.5.2, PUP 4.5.3, PUP 4.6.0, PUP 4.6.1, PUP 4.6.2, PUP 4.7.0, PUP 4.8.0, PUP 4.8.1
    • Fix Version/s: None
    • Component/s: None
    • Environment:

      {{# cat /etc/redhat-release
      Red Hat Enterprise Linux Server release 7.2 (Maipo)

      1. puppet --version
        4.6.2}}
    • Template:
    • Team:
      Night's Watch
    • QA Risk Assessment:
      Needs Assessment

      Description

      While attempting to install a specific version of a package using the package resource, we encountered an issue introduced in commit 3a548510ee10e58a37b66b75ebd73a24d2e2d713.

      The RPM has 'x86_64' as part of the release tag. Attempting to install this with {{ ensure => "version" }} syntax now fails.

        Attachments

          Issue Links

            Activity

              People

              Assignee:
              Unassigned
              Reporter:
              hanleyja Jesse Hanley
              Votes:
              0 Vote for this issue
              Watchers:
              2 Start watching this issue

                Dates

                Created:
                Updated:

                  Zendesk Support