Uploaded image for project: 'Puppet'
  1. Puppet
  2. PUP-7013

Raise errors if hiera.yaml version 4 is used globally

    Details

    • Type: Bug
    • Status: Closed
    • Priority: Normal
    • Resolution: Fixed
    • Affects Version/s: None
    • Fix Version/s: PUP 4.9.0
    • Component/s: None
    • Labels:
      None
    • Template:
    • Acceptance Criteria:
      Hide

      An attempt to use a hiera.yaml with version 4 results in an error.

      Show
      An attempt to use a hiera.yaml with version 4 results in an error.
    • Team:
      Puppet Developer Experience
    • Story Points:
      1
    • Sprint:
      PDE 2016-12-14, PDE 2017-01-11
    • Release Notes:
      Bug Fix
    • Release Notes Summary:
      if an hiera.yaml version 4 was referenced as the global hiera.yaml the system would silently fall back to the factory-default hiera.yaml. Now it will instead error.
    • QA Risk Assessment:
      No Action
    • QA Risk Assessment Reason:
      covered by unit tests; error message

      Description

      Since PUP-6980 (not yet released), it is possible to use a hiera.yaml version 4 in the global layer. It shouldn't be. Only version 3 and version 5 should be allowed in global scope.

        Attachments

          Activity

            People

            • Assignee:
              Unassigned
              Reporter:
              thomas.hallgren Thomas Hallgren
            • Votes:
              0 Vote for this issue
              Watchers:
              3 Start watching this issue

              Dates

              • Created:
                Updated:
                Resolved:

                Zendesk Support