Details

    • Type: Task
    • Status: Closed
    • Priority: Normal
    • Resolution: Fixed
    • Affects Version/s: None
    • Fix Version/s: PUP 4.9.0
    • Component/s: None
    • Labels:
    • Template:
    • Acceptance Criteria:
      Hide

      Deprecation message emitted at beginning of a Puppet run.

      Show
      Deprecation message emitted at beginning of a Puppet run.
    • Team:
      Agent
    • Story Points:
      1
    • Sprint:
      AP 2017-01-11, AP 2017-01-25
    • Release Notes:
      Deprecation
    • Release Notes Summary:
      As of Puppet 4.9.0, support for the ruby 2.0 series is deprecated.
    • QA Risk Assessment:
      No Action
    • QA Risk Assessment Reason:
      Build, test, documentation, infra tickets not risk-assessed

      Description

      Ruby 2.0 was EOL'd February 24th 2016 which means security patch support will likely end ~Feb 2017.

      Issue deprecation warnings to users on ruby 2.0.0 - we will EOL ruby 2.0.0 support in Puppet in a later version (Puppet 6?).

        Attachments

          Issue Links

            Activity

              People

              • Assignee:
                Unassigned
                Reporter:
                moses Moses Mendoza
              • Votes:
                0 Vote for this issue
                Watchers:
                2 Start watching this issue

                Dates

                • Created:
                  Updated:
                  Resolved:

                  Zendesk Support