Uploaded image for project: 'Puppet'
  1. Puppet
  2. PUP-7056

Could not retrieve facts for node-5.domain.tld: invalid byte sequence in UTF-8

    XMLWordPrintable

    Details

    • Type: Bug
    • Status: Closed
    • Priority: Normal
    • Resolution: Fixed
    • Affects Version/s: PUP 3.8.5
    • Fix Version/s: None
    • Component/s: None
    • Labels:
      None
    • Template:
    • Acceptance Criteria:
      Hide

      Move further on Fuel Openstack/OPNFV deployment

      Show
      Move further on Fuel Openstack/OPNFV deployment
    • Team:
      Agent
    • QA Risk Assessment:
      Needs Assessment

      Description

      Hi, I am trying to deploy Fuel-OpenStack with OPNFV. I got the below error while deploying OPNFV. The version of Puppet is Puppet v3.8.5. Could someone let me know the resolution on this ?

      2017-01-03 02:38:07 ERR /usr/bin/puppet:8:in `<main>'
      2017-01-03 02:38:07 ERR /usr/lib/ruby/vendor_ruby/puppet/util/command_line.rb:92:in `execute'
      2017-01-03 02:38:07 ERR /usr/lib/ruby/vendor_ruby/puppet/util/command_line.rb:146:in `run'
      2017-01-03 02:38:07 ERR /usr/lib/ruby/vendor_ruby/puppet/application.rb:381:in `run'
      2017-01-03 02:38:07 ERR /usr/lib/ruby/vendor_ruby/puppet/util.rb:496:in `exit_on_fail'
      2017-01-03 02:38:07 ERR /usr/lib/ruby/vendor_ruby/puppet/application.rb:381:in `block in run'
      2017-01-03 02:38:07 ERR /usr/lib/ruby/vendor_ruby/puppet/application.rb:507:in `plugin_hook'
      2017-01-03 02:38:07 ERR /usr/lib/ruby/vendor_ruby/puppet/application.rb:381:in `block (2 levels) in run'
      2017-01-03 02:38:07 ERR /usr/lib/ruby/vendor_ruby/puppet/application/apply.rb:159:in `run_command'
      2017-01-03 02:38:07 ERR /usr/lib/ruby/vendor_ruby/puppet/application/apply.rb:198:in `main'
      2017-01-03 02:38:07 ERR /usr/lib/ruby/vendor_ruby/puppet.rb:246:in `override'
      2017-01-03 02:38:07 ERR /usr/lib/ruby/vendor_ruby/puppet/context.rb:64:in `override'
      2017-01-03 02:38:07 ERR /usr/lib/ruby/vendor_ruby/puppet/application/apply.rb:200:in `block in main'
      2017-01-03 02:38:07 ERR /usr/lib/ruby/vendor_ruby/puppet/indirector/indirection.rb:201:in `find'
      2017-01-03 02:38:07 ERR /usr/lib/ruby/vendor_ruby/puppet/indirector/node/plain.rb:17:in `find'
      2017-01-03 02:38:07 ERR /usr/lib/ruby/vendor_ruby/puppet/node.rb:125:in `fact_merge'
      2017-01-03 02:38:07 ERR /usr/lib/ruby/vendor_ruby/puppet/indirector/indirection.rb:201:in `find'
      2017-01-03 02:38:07 ERR /usr/lib/ruby/vendor_ruby/puppet/indirector/facts/facter.rb:23:in `find'
      2017-01-03 02:38:07 ERR /usr/lib/ruby/vendor_ruby/facter.rb:118:in `block (2 levels) in singletonclass'
      2017-01-03 02:38:07 ERR /usr/lib/ruby/vendor_ruby/facter/util/collection.rb:115:in `load_all'
      2017-01-03 02:38:07 ERR /usr/lib/ruby/vendor_ruby/facter/util/loader.rb:38:in `load_all'
      2017-01-03 02:38:07 ERR /usr/lib/ruby/vendor_ruby/facter/util/loader.rb:38:in `each'
      2017-01-03 02:38:07 ERR /usr/lib/ruby/vendor_ruby/facter/util/loader.rb:41:in `block in load_all'
      2017-01-03 02:38:07 ERR /usr/lib/ruby/vendor_ruby/facter/util/loader.rb:41:in `each'
      2017-01-03 02:38:07 ERR /usr/lib/ruby/vendor_ruby/facter/util/loader.rb:46:in `block (2 levels) in load_all'
      2017-01-03 02:38:07 ERR /usr/lib/ruby/vendor_ruby/facter/util/loader.rb:95:in `load_file'
      2017-01-03 02:38:07 ERR /usr/lib/ruby/vendor_ruby/facter/util/loader.rb:95:in `load'
      2017-01-03 02:38:07 ERR /usr/lib/ruby/vendor_ruby/facter/manufacturer.rb:66:in `<top (required)>'
      2017-01-03 02:38:07 ERR /usr/lib/ruby/vendor_ruby/facter/util/manufacturer.rb:34:in `dmi_find_system_info'
      2017-01-03 02:38:07 ERR /usr/lib/ruby/vendor_ruby/facter/util/manufacturer.rb:34:in `each_pair'
      2017-01-03 02:38:07 ERR /usr/lib/ruby/vendor_ruby/facter/util/manufacturer.rb:35:in `block in dmi_find_system_info'
      2017-01-03 02:38:07 ERR /usr/lib/ruby/vendor_ruby/facter/util/manufacturer.rb:35:in `each'
      2017-01-03 02:38:07 ERR /usr/lib/ruby/vendor_ruby/facter/util/manufacturer.rb:36:in `block (2 levels) in dmi_find_system_info'
      2017-01-03 02:38:07 ERR /usr/lib/ruby/vendor_ruby/facter/util/manufacturer.rb:36:in `each_pair'
      2017-01-03 02:38:07 ERR /usr/lib/ruby/vendor_ruby/facter/util/manufacturer.rb:37:in `block (3 levels) in dmi_find_system_info'
      2017-01-03 02:38:07 ERR /usr/lib/ruby/vendor_ruby/facter/util/manufacturer.rb:37:in `split'
      2017-01-03 02:38:07 ERR Could not run: Could not retrieve facts for node-5.domain.tld: invalid byte sequence in UTF-8

        Attachments

          Activity

            People

            Assignee:
            vvenkat Venkat
            Reporter:
            vvenkat Venkat
            Votes:
            0 Vote for this issue
            Watchers:
            3 Start watching this issue

              Dates

              Created:
              Updated:
              Resolved:

                Zendesk Support