Uploaded image for project: 'Puppet'
  1. Puppet
  2. PUP-7115

Un-vendor semantic_puppet gem for Puppet 6

    Details

    • Type: Task
    • Status: Closed
    • Priority: Minor
    • Resolution: Fixed
    • Affects Version/s: PUP 4.9.0
    • Fix Version/s: PUP 6.0.0
    • Component/s: None
    • Labels:
      None
    • Template:
    • Acceptance Criteria:
      Hide

      Add hard gem dependency on the external semantic_puppet gem. We should require "~> 1.0" accept at least 1.0 or greater and less than 2.0.
      The gem dependency needs to be updated in 3 places: .gemspec, Gemfile and ext/project_data.yaml.
      Delete lib/puppet/vendor/load_semantic_puppet.rb and lib/puppet/vendor/semantic_puppet/
      If you build a puppet gem (bundle exec rake package:implode package:bootstrap and bundle exec rake package:gem), then you should be able install each version (there will be 4 platforms) on a clean VM and it should install the semantic_puppet gem 1.0.x as an external dependency.

      Show
      Add hard gem dependency on the external semantic_puppet gem. We should require "~> 1.0" accept at least 1.0 or greater and less than 2.0. The gem dependency needs to be updated in 3 places: .gemspec, Gemfile and ext/project_data.yaml. Delete lib/puppet/vendor/load_semantic_puppet.rb and lib/puppet/vendor/semantic_puppet/ If you build a puppet gem (bundle exec rake package:implode package:bootstrap and bundle exec rake package:gem), then you should be able install each version (there will be 4 platforms) on a clean VM and it should install the semantic_puppet gem 1.0.x as an external dependency.
    • Team:
      Coremunity
    • Sub-team:
    • Sprint:
      Platform Core KANBAN
    • Release Notes:
      Bug Fix
    • Release Notes Summary:
      Puppet now loads semantic_puppet from a shared gem directory, so that Puppet, Puppet agent, and Puppet Server all require and use the same version of the gem. (~>1.0.x)
    • QA Risk Assessment:
      Needs Assessment

      Description

      In PUP-7114 the semantic_puppet gem was re-vendored into the Puppet repo to prevent packaging conflicts.

      In Puppet 5, there will be more latitude to introduce a breaking packaging change that must be coordinated with a server release - and at that point the work from PUP-7114 can be reverted.

        Attachments

          Issue Links

            Activity

              jsd-sla-details-panel

                People

                • Assignee:
                  jorie Jorie Tappa
                  Reporter:
                  ethan Ethan Brown
                • Votes:
                  0 Vote for this issue
                  Watchers:
                  5 Start watching this issue

                  Dates

                  • Created:
                    Updated:
                    Resolved: