Details

    • Type: Task
    • Status: Closed
    • Priority: Blocker
    • Resolution: Fixed
    • Affects Version/s: None
    • Fix Version/s: PUP 4.9.0
    • Component/s: None
    • Labels:
      None
    • Template:
    • Acceptance Criteria:
      Hide

      Puppet does not crash when the gettext-setup gem cannot be found.

      Show
      Puppet does not crash when the gettext-setup gem cannot be found.
    • Team:
      Agent
    • Story Points:
      1
    • Sprint:
      AP 2017-01-25, AP 2017-02-08
    • Release Notes:
      Not Needed
    • Release Notes Summary:
      No change from currently released behavior or dependencies. We are pushing back the introduction of a hard dependency on the gettext-setup gem to Puppet 5.
    • QA Risk Assessment:
      No Action
    • QA Risk Assessment Reason:
      Build, test, infrastructure tickets not risk-assessed

      Description

      We cannot require that puppetserver provide the gettext-setup gem for the 1.9.0 release, so we need to update Puppet to behave correctly even when the gem isn't present. This involves stubbing the _() method used extract strings and pull in translations.

        Attachments

          Issue Links

            Activity

              People

              • Assignee:
                maggie Maggie Dreyer
                Reporter:
                maggie Maggie Dreyer
              • Votes:
                0 Vote for this issue
                Watchers:
                3 Start watching this issue

                Dates

                • Created:
                  Updated:
                  Resolved:

                  Zendesk Support