Uploaded image for project: 'Puppet'
  1. Puppet
  2. PUP-7157

Remove 'semantic' shim in Puppet 6

    Details

    • Type: Task
    • Status: Closed
    • Priority: Normal
    • Resolution: Fixed
    • Affects Version/s: None
    • Fix Version/s: PUP 6.0.0
    • Component/s: None
    • Labels:
      None
    • Template:
    • Acceptance Criteria:
      Hide
      • "semantic" shim added in PUP-7156 is removed (lib/puppet/vendor/load_semantic.rb and lib/puppet/vendor/semantic).
      • Make sure a newly generated module from the pdk or garethr's puppet-module-skeleton does not have the same issue described in PUP-7156.
      Show
      "semantic" shim added in PUP-7156 is removed (lib/puppet/vendor/load_semantic.rb and lib/puppet/vendor/semantic). Make sure a newly generated module from the pdk or garethr's puppet-module-skeleton does not have the same issue described in PUP-7156 .
    • Team:
      Coremunity
    • Sub-team:
    • Story Points:
      1
    • Sprint:
      Platform Core KANBAN
    • Release Notes:
      Bug Fix
    • Release Notes Summary:
      Puppet now uses the shared gem dependency for semantic_puppet, rather than loading its own vendored version.
    • QA Risk Assessment:
      Needs Assessment

      Description

      PUP-7156 adds a shim to puppet's vendor dir so that users who explicitly required 'semantic' are redirected to 'semantic_puppet'.

      This ticket is to remove the shim.

        Attachments

          Issue Links

            Activity

              jsd-sla-details-panel

                People

                • Assignee:
                  jorie Jorie Tappa
                  Reporter:
                  moses Moses Mendoza
                • Votes:
                  0 Vote for this issue
                  Watchers:
                  3 Start watching this issue

                  Dates

                  • Created:
                    Updated:
                    Resolved: