Uploaded image for project: 'Puppet'
  1. Puppet
  2. PUP-736

Encoding mis-matches cause package prefetching to fail

    Details

    • Template:
    • Story Points:
      1
    • Sprint:
      Week 2014-1-2 to 2014-1-8, Week 2014-1-8 to 2014-1-15

      Description

      One of our RPM packages has some UTF-8 characters in its description, leading to an exception ("Error: Could not prefetch package provider 'yum': invalid byte sequence in US-ASCII") in rpm.rb, causing no packages to be upgraded as the yumhelper.py invocation code raises that error.

      Priority=High because it breaks file

      { ensure => latest; }

      .

        Attachments

          Issue Links

            Activity

              jsd-sla-details-panel

                People

                • Assignee:
                  Unassigned
                  Reporter:
                  redmine.exporter redmine.exporter
                • Votes:
                  1 Vote for this issue
                  Watchers:
                  17 Start watching this issue

                  Dates

                  • Created:
                    Updated:
                    Resolved: