Uploaded image for project: 'Puppet'
  1. Puppet
  2. PUP-7367

Replace use of "fail" in puppet code base when it is not the Ruby alias for "raise"

    XMLWordPrintable

    Details

    • Type: Bug
    • Status: Accepted
    • Priority: Minor
    • Resolution: Unresolved
    • Affects Version/s: None
    • Fix Version/s: None
    • Component/s: None
    • Template:
    • Epic Link:
    • Sub-team:
    • Team:
      Froyo
    • Story Points:
      1
    • QA Risk Assessment:
      Needs Assessment

      Description

      We are using the method fail in a couple of places in the puppet code base to deal with the issuing of an error (it ultimately leads to a raised error). The problem with using the name fail is that it is also an alias for raise and for newcomers to the puppet code base, the unorthodox use of fail may be confusing.

      Suggested name: raise_issue, and in the cases where the "raise" is optional optionally_raise_issue (when the issue is configurable as warning or error).

        Attachments

          Activity

            People

            Assignee:
            Unassigned
            Reporter:
            henrik.lindberg Henrik Lindberg
            Votes:
            0 Vote for this issue
            Watchers:
            1 Start watching this issue

              Dates

              Created:
              Updated:

                Zendesk Support