Uploaded image for project: 'Puppet'
  1. Puppet
  2. PUP-7555

Update default fileserver.conf that allow/deny are no longer allowed

    XMLWordPrintable

    Details

    • Type: Bug
    • Status: Closed
    • Priority: Normal
    • Resolution: Fixed
    • Affects Version/s: None
    • Fix Version/s: PUP 5.0.0
    • Component/s: None
    • Labels:
      None
    • Template:
    • Acceptance Criteria:
      Hide

      See description for details.

      Show
      See description for details.
    • Epic Link:
    • Sub-team:
    • Team:
      Systems Engineering
    • Story Points:
      1
    • Sprint:
      Server 2017-06-14
    • Release Notes:
      Deprecation
    • QA Risk Assessment:
      Needs Assessment

      Description

      We are removing allow/deny directives from fileserver.conf. See PUP-6359. This ticket is about updating the Permissions section in the default fileserver.conf to explain that allow and deny directives should be set in the ruby auth.conf if using legacy auth.conf, or in trapperkeeper's tk-auth.

        Attachments

          Issue Links

            Activity

              People

              Assignee:
              jeremy.barlow Jeremy Barlow
              Reporter:
              josh Josh Cooper
              Votes:
              0 Vote for this issue
              Watchers:
              1 Start watching this issue

                Dates

                Created:
                Updated:
                Resolved:

                  Zendesk Support