Uploaded image for project: 'Puppet'
  1. Puppet
  2. PUP-7571

Add ability to relax VersionRange constraints so that they include pre-releases

    XMLWordPrintable

Details

    • Improvement
    • Status: Closed
    • Normal
    • Resolution: Fixed
    • None
    • PUP 5.0.0
    • Docs
    • None
    • Agent
    • 1
    • Agent 2017-05-31
    • New Feature
    • The flag --strict-semver was added to the puppet module commands install, list, uninstall, and upgrade. When used, module dependencies will be resolved using the strict semver-range behavior specified by node semver.
    • No Action

    Description

      The strict interpretation of the semantic version ranges introduced in SemanticPuppet version 1.0.0 is causing problems for PEZ and perhaps for the Puppet community. The problem is that a strict version range excludes all pre-releases unless it explicitly appoints pre-releases for any given major, minor, patch triplet.

      In Puppet, we need a way to relax this constraint so that pre-releases of a higher version are included. A range like >=1.2.3 should include the pre-release version 1.2.4-rc0 but it should not include 1.2.3-rc0 since a pre-release is considered less than a release.

      The Puppet module tool must be configurable so that it can choose to use either the relaxed interpretation suggested here or the strict one.

      Attachments

        Issue Links

          Activity

            People

              Unassigned Unassigned
              thomas.hallgren Thomas Hallgren
              Eric Delaney Eric Delaney
              Votes:
              0 Vote for this issue
              Watchers:
              3 Start watching this issue

              Dates

                Created:
                Updated:
                Resolved:

                Zendesk Support