Uploaded image for project: 'Puppet'
  1. Puppet
  2. PUP-7624

Log Messages no longer register certain characters in the UTF-8 format

    XMLWordPrintable

    Details

    • Type: Bug
    • Status: Closed
    • Priority: Critical
    • Resolution: Duplicate
    • Affects Version/s: None
    • Fix Version/s: None
    • Component/s: None
    • Labels:
    • Template:
    • Method Found:
      Needs Assessment
    • QA Risk Assessment:
      Needs Assessment

      Description

      Log messages created and displayed by puppet are no longer displaying certain characters in the UTF-8 format. Common symbols such as '@' and '#' are displayed fine but any character not native to the english language seems to be replaced with a variation of '\u

      {4E07}

      '.
      The characters are shown and stored correctly when set as such, and the problem seems to be unique to information generated by puppet itself and after further attention it seems as though this problem originates from the puppet language itself.
      Please view the attached file for an example of a set of reports where this problem has occurred.

        Attachments

          Issue Links

            Activity

              People

              Assignee:
              Unassigned
              Reporter:
              david.swan David Swan
              Votes:
              0 Vote for this issue
              Watchers:
              5 Start watching this issue

                Dates

                Created:
                Updated:
                Resolved:

                  Zendesk Support