Uploaded image for project: 'Puppet'
  1. Puppet
  2. PUP-7645

Ensure that translations are available in released puppet gems

    Details

    • Type: Task
    • Status: Closed
    • Priority: Normal
    • Resolution: Fixed
    • Affects Version/s: None
    • Fix Version/s: PUP 5.2.0
    • Component/s: None
    • Labels:
      None
    • Template:
    • Acceptance Criteria:
      Hide

      MO files are packaged in the puppet gem so that translations can be loaded

      Show
      MO files are packaged in the puppet gem so that translations can be loaded
    • Team:
      Platform Core
    • Story Points:
      2
    • Sprint:
      Platform Core 2017-09-05, Platform Core 2017-08-08, Platform Core 2017-08-22
    • Release Notes:
      New Feature
    • QA Risk Assessment:
      Manual

      Description

      We do not currently commit any MO files to the Puppet repo: they are built in vanagon packaging and installed along with the Agent. If we want to support i18n in the Puppet gem, we need to make sure we compile these files during gem packaging as well. Alternatively, we need to revisit the decision to not commit these files.

      UPDATE The easiest solution may be to use PO files instead of MO files when running from source or as a gem.

      If translations are not going to be supported when using the Puppet gem, this ticket can be closed.

        Attachments

          Issue Links

            Activity

              jsd-sla-details-panel

                People

                • Assignee:
                  eric.delaney Eric Delaney
                  Reporter:
                  maggie Maggie Dreyer
                • Votes:
                  0 Vote for this issue
                  Watchers:
                  4 Start watching this issue

                  Dates

                  • Created:
                    Updated:
                    Resolved: