Uploaded image for project: 'Puppet'
  1. Puppet
  2. PUP-7816

Package resource' ensure attribute to use Semantic Versioning

    Details

    • Template:
    • Team:
      Platform OS
    • QA Risk Assessment:
      Needs Assessment

      Description

      I wanted to ensure that puppet-agent 1.9.0 was not allowed on my boxes and realized there was no way for me to do so without resorting to RPM version string. I don't want to pin it to 1.8.4 or 1.9.2, nor do I want to play roulette and specify 'latest' since broken builds show up from time to time. I should be able to specify the well-known nomenclature that Module metatdata.json uses.

      ensure =>  ">= 4.8.2 < 5.0.0"
      

      References

        Attachments

          Issue Links

            Activity

              People

              • Assignee:
                Unassigned
                Reporter:
                snowy-owl Matthew Patton
              • Votes:
                0 Vote for this issue
                Watchers:
                2 Start watching this issue

                Dates

                • Created:
                  Updated:

                  Zendesk Support