Uploaded image for project: 'Puppet'
  1. Puppet
  2. PUP-7820

error string needs update for I18N support

    Details

    • Type: Bug
    • Status: Closed
    • Priority: Normal
    • Resolution: Fixed
    • Affects Version/s: PUP 5.0.1
    • Fix Version/s: PUP 5.2.0
    • Component/s: None
    • Labels:
      None
    • Template:
    • Team:
      Platform Core
    • Story Points:
      2
    • Sprint:
      Platform Core 2017-09-05, Platform Core 2017-08-08, Platform Core 2017-08-22
    • Method Found:
      Inspection
    • Release Notes:
      Not Needed
    • QA Risk Assessment:
      No Action

      Description

      While doing I18N testing I noticed this error message in the puppet.po file which should be updated for I18N

      #: ../lib/puppet/pops/issues.rb:755
      msgid "\"#

      {label.a_an_uc(semantic)}

      resulted in a value outside of Puppet Integer #

      {range_end}

      range, got '#

      {\"%#+x\" % value}

      '\""
      msgstr ""
      "\"#

      {ŀȧƀḗŀ.ȧ_ȧƞ_ŭƈ(şḗḿȧƞŧīƈ)}

      řḗşŭŀŧḗḓ īƞ ȧ ṽȧŀŭḗ ǿŭŧşīḓḗ ǿƒ Ƥŭƥƥḗŧ Īƞŧḗɠḗř "
      "#

      {řȧƞɠḗ_ḗƞḓ}

      řȧƞɠḗ, ɠǿŧ '#

      {\"%#+ẋ\" % ṽȧŀŭḗ}

      '\""

      And another

      #: ../lib/puppet/pops/issues.rb:444
      msgid "\"#

      {label.article(actual_type)}

      #

      {actual_type}

      \""
      msgstr ""

      And another

      "The string '#

      {before}

      ' was automatically coerced to the numerical value #

      {after}

      "

        Attachments

          Issue Links

            Activity

              jsd-sla-details-panel

                People

                • Assignee:
                  eric.delaney Eric Delaney
                  Reporter:
                  eric.delaney Eric Delaney
                  QA Contact:
                  Eric Delaney
                • Votes:
                  0 Vote for this issue
                  Watchers:
                  1 Start watching this issue

                  Dates

                  • Created:
                    Updated:
                    Resolved: