Uploaded image for project: 'Puppet'
  1. Puppet
  2. PUP-7881

puppet gem prints ruby version warning in Japanese

    Details

    • Type: Bug
    • Status: Closed
    • Priority: Normal
    • Resolution: Fixed
    • Affects Version/s: PUP 5.1.0
    • Fix Version/s: PUP 5.2.0
    • Component/s: None
    • Labels:
      None
    • Template:
    • Team:
      Platform Core
    • Story Points:
      1
    • Sprint:
      Platform Core 2017-09-05, Platform Core KANBAN
    • Method Found:
      Needs Assessment
    • Release Notes:
      Not Needed
    • QA Risk Assessment:
      Manual

      Description

      I was testing a development built version of the puppet gem. The system in questions has Ruby 2.0.0 which causes a warning to be printed. However its always printed in Japanese

      [root@vok2pfwd7v6dx6t ~]# puppet --help
      Warning: rubyバージョン2.0.0のサポートは廃止予定であり、今後のリリースで廃止されます。サポートされているrubyのバージョンについては、https://docs.puppet.com/puppet/latest/system_requirements.html#rubyを参照してください。
         (/usr/local/share/gems/gems/puppet-5.1.0.118/lib/puppet.rb:134:in `<module:Puppet>'において)
       
      Usage: puppet <subcommand> [options] <action> [options]
       
      Available subcommands:
       
        agent             The puppet agent daemon
        apply             Apply Puppet manifests locally
        ca                Local Puppet Certificate Authority management. (Deprecated)
        catalog           Compile, save, view, and convert catalogs.
        cert              Manage certificates and requests
        certificate       Provide access to the CA for certificate management.
        certificate_request  Manage certificate requests. (Deprecated)
        certificate_revocation_list  Manage the list of revoked certificates. (Deprecated)
        config            Interact with Puppet's settings.
        describe          Display help about resource types
        device            Manage remote network devices
        doc               Generate Puppet references
        epp               Interact directly with the EPP template parser/renderer.
        facts             Retrieve and store facts.
        filebucket        Store and retrieve files in a filebucket
        generate          Generates Puppet code from Ruby definitions.
        help              Display Puppet help.
        key               Create, save, and remove certificate keys. (Deprecated)
        lookup            Interactive Hiera lookup
        man               Display Puppet manual pages.
        master            The puppet master daemon
        module            Creates, installs and searches for modules on the Puppet Forge.
        node              View and manage node definitions.
        parser            Interact directly with the parser.
        plugin            Interact with the Puppet plugin system.
        report            Create, display, and submit reports.
        resource          The resource abstraction layer shell
        status            View puppet server status. (Deprecated)
       
      See 'puppet help <subcommand> <action>' for help on a specific subcommand action.
      See 'puppet help <subcommand>' for help on a specific subcommand.
      Puppet v5.1.0
      [root@vok2pfwd7v6dx6t ~]#
      

      I only have the LANG environment variable set to its default

      LANG=en_US.UTF-8

      So something weird is happening while things are initializing.

        Attachments

          Issue Links

            Activity

              People

              • Assignee:
                maggie Maggie Dreyer
                Reporter:
                eric.delaney Eric Delaney
              • Votes:
                0 Vote for this issue
                Watchers:
                3 Start watching this issue

                Dates

                • Created:
                  Updated:
                  Resolved:

                  Zendesk Support