Uploaded image for project: 'Puppet'
  1. Puppet
  2. PUP-8082

Add warning to Puppet Module Tool when installing a deprecated module

    Details

    • Type: Improvement
    • Status: Closed
    • Priority: Normal
    • Resolution: Fixed
    • Affects Version/s: None
    • Fix Version/s: PUP 5.4.0
    • Component/s: PMT
    • Labels:
      None
    • Template:
    • Acceptance Criteria:
      • PMT emits a warning for deprecated modules, including a link to Forge.
    • Team:
      Puppet Developer Experience
    • Story Points:
      2
    • Sprint:
      PDE 2017-03-08, PDE 2017-03-22, PDE 2017-04-05, PDE 2017-04-19, PDE 2017-05-03, PDE 2017-05-31
    • Release Notes:
      New Feature
    • Release Notes Summary:
      The Puppet Module Tool (PMT) will now warn users when interacting with Forge modules that have been "deprecated" by their author.
    • QA Risk Assessment:
      Manual

      Description

      When PMT is installing a deprecated module (either directly or as a dependency of another module) it should emit a warning. The warning should include a link to the Forge module detail page of the deprecated module so that the user can investigate.

        Attachments

          Activity

            jsd-sla-details-panel

              People

              • Assignee:
                Unassigned
                Reporter:
                jesse Jesse Scott
              • Votes:
                0 Vote for this issue
                Watchers:
                6 Start watching this issue

                Dates

                • Created:
                  Updated:
                  Resolved:

                  Zendesk Support