Uploaded image for project: 'Puppet'
  1. Puppet
  2. PUP-8111

Unsigned Redhat 5 guid rpm causes yum provider package test to fail

    Details

    • Type: CI Blocker
    • Status: Closed
    • Priority: Normal
    • Resolution: Fixed
    • Affects Version/s: None
    • Fix Version/s: PUP 5.3.4
    • Component/s: None
    • Labels:
      None
    • Release Notes:
      Not Needed
    • QA Risk Assessment:
      Needs Assessment

      Description

      The failed job:
      https://jenkins-master-prod-1.delivery.puppetlabs.net/job/platform_puppet-agent_puppet-agent-integration-suite_daily-master/COMPONENT=puppet,SLAVE_LABEL=beaker,TEST_TARGET=redhat5-64a/10/

      Relevant error text:

                                                                      Total size: 29 
                                                                      Downloading Packages:
                                                                      
                                                                      
                                                                      Package guid-1.0-1.noarch.rpm is not signed
                                                                      Error: /Stage[main]/Main/Package[guid]/ensure: change from 'purged' to 'present' failed: Execution of '/usr/bin/yum -e 0 -y install /tmp/rpmrepo/RPMS/noarch/guid-1.0-1.noarch.rpm' returned 1: Loaded plugins: product-id, security
                                                                      Setting up Install Process
                                                                      Examining /tmp/rpmrepo/RPMS/noarch/guid-1.0-1.noarch.rpm: guid-1.0-1.noarch
                                                                      Marking /tmp/rpmrepo/RPMS/noarch/guid-1.0-1.noarch.rpm to be installed
                                                                      Resolving Dependencies
                                                                      --> Running transaction check
                                                                      ---> Package guid.noarch 0:1.0-1 set to be updated
                                                                      --> Finished Dependency Resolution
                                                                      
                                                                      Dependencies Resolved
      

      then:

                                                                    Minitest::Assertion: Expected /Package\[guid\]\/ensure:\ created/ to match "redhat5-64-1: \e[mNotice: Compiled catalog for ppmr1lulo5okinp.delivery.puppetlabs.net in environment production in 0.44 seconds\e[0m\n\e[0;32mInfo: Applying configuration version '1509553721'\e[0m\n\e[mNotice: Applied catalog in 1.73 seconds\e[0m\n".
      

        Attachments

          Issue Links

            Activity

              People

              • Assignee:
                Unassigned
                Reporter:
                casey.williams Casey Williams
              • Votes:
                0 Vote for this issue
                Watchers:
                2 Start watching this issue

                Dates

                • Created:
                  Updated:
                  Resolved:

                  Zendesk Support