Uploaded image for project: 'Puppet'
  1. Puppet
  2. PUP-8196

Variant does not accept false as type with puppet-5 anylonger

    XMLWordPrintable

    Details

    • Type: Bug
    • Status: Closed
    • Priority: Normal
    • Resolution: Incomplete
    • Affects Version/s: PUP 5.3.3
    • Fix Version/s: None
    • Component/s: Language
    • Labels:
      None
    • Template:
    • Team:
      Platform Core
    • Method Found:
      Needs Assessment
    • QA Risk Assessment:
      Needs Assessment

      Description

      We have some data types for logrotate parameters that verify if the mail parameter (https://github.com/voxpupuli/puppet-logrotate/blob/d55a64e670aa192fe6257289b023e706d24c41e7/manifests/rule.pp#L238) is either false (Boolean) or a valid email address.

      mail            => Optional[Variant[false ,Sys11lib::Type::Email]],
      

      This works with puppet-4.10.1, but puppet-5.3 throws:

      Error while evaluating a Type-Name, The expression <Variant[false,Sys11lib::Type::Email]> is not a valid type specification.
      

      How do we specify a subtype of a Boolean with Puppet5 (that is compatible with Puppet4)?

        Attachments

          Activity

            People

            Assignee:
            Unassigned
            Reporter:
            sandres Stefan Andres
            Votes:
            0 Vote for this issue
            Watchers:
            4 Start watching this issue

              Dates

              Created:
              Updated:
              Resolved:

                Zendesk Support