Uploaded image for project: 'Puppet'
  1. Puppet
  2. PUP-8268

Install packages using beaker-puppet's puppet5 methods

    Details

    • Type: Improvement
    • Status: Closed
    • Priority: Normal
    • Resolution: Fixed
    • Affects Version/s: None
    • Fix Version/s: PUP 4.10.11, PUP 5.3.4
    • Component/s: None
    • Labels:
      None
    • Release Notes:
      Not Needed
    • QA Risk Assessment:
      No Action

      Description

      Modify the AIO 010_Install.rb step to call beaker's new install_from_build_data_url method to install puppet-agent on each host. This should work for all supported platforms including those without a package manager. We should add a gem dependency (from the acceptance Gemfile) on beaker-puppet since we're directly relying on methods provided by that gem. Also need to bump our beaker-hostgenerator dependency because we rely on packaging_platform when installing the package.

        Attachments

          Issue Links

            Activity

              People

              • Assignee:
                melissa Melissa Stone
                Reporter:
                josh Josh Cooper
              • Votes:
                0 Vote for this issue
                Watchers:
                1 Start watching this issue

                Dates

                • Created:
                  Updated:
                  Resolved:

                  Zendesk Support