Uploaded image for project: 'Puppet'
  1. Puppet
  2. PUP-8375

Amazon Linux v2 detection is broken (os.version is 2.0, not 2017.12)

    Details

    • Type: Bug
    • Status: Closed
    • Priority: Blocker
    • Resolution: Fixed
    • Affects Version/s: None
    • Fix Version/s: PUP 4.10.10, PUP 5.3.4, PUP 5.4.0
    • Component/s: None
    • Labels:
      None
    • Release Notes:
      Not Needed
    • QA Risk Assessment:
      Needs Assessment

      Description

      Previous to the release of Amazon Linux v2, facter reported the version of Amazon Linux as a date-based string, e.g "2017.09". In Amazon Linux v2, this has changed to "2.0".

      The code changes previously made in Puppet's service provider code and acceptance tests have incorrectly assumed that Amazon Linux v2 returns a version of "2017.12" and will need to be updated to work with "2.0" instead.

        Attachments

          Issue Links

            Activity

              People

              • Assignee:
                scott.garman Scott Garman
                Reporter:
                scott.garman Scott Garman
              • Votes:
                0 Vote for this issue
                Watchers:
                2 Start watching this issue

                Dates

                • Created:
                  Updated:
                  Resolved:

                  Zendesk Support