Details

    • Type: Bug
    • Status: Closed
    • Priority: Normal
    • Resolution: Fixed
    • Affects Version/s: None
    • Fix Version/s: PUP 6.0.0
    • Component/s: None
    • Labels:
      None
    • Release Notes:
      Bug Fix
    • Release Notes Summary:
      Puppet requires ruby 2.3 or greater.
    • QA Risk Assessment:
      Needs Assessment

      Description

      Update Gemfile, .gemspec, ext/project_data.yaml so that puppet requires ruby 2.3 or greater.

      Attempting to install puppet as a gem, running puppet via bundler, or running module tests using a local checkout of puppet should all fail when using ruby < 2.3.

        Attachments

          Activity

            jsd-sla-details-panel

              People

              • Assignee:
                Unassigned
                Reporter:
                josh Josh Cooper
              • Votes:
                0 Vote for this issue
                Watchers:
                1 Start watching this issue

                Dates

                • Created:
                  Updated:
                  Resolved: