Uploaded image for project: 'Puppet'
  1. Puppet
  2. PUP-8504

Emit deprecation warning for ruby 2.1 and 2.2

    Details

    • Type: Improvement
    • Status: Closed
    • Priority: Normal
    • Resolution: Fixed
    • Affects Version/s: None
    • Fix Version/s: PUP 5.5.1
    • Component/s: None
    • Labels:
      None
    • Release Notes:
      Deprecation
    • Release Notes Summary:
      Ruby versions less than 2.3 are now deprecated and will be removed in Puppet 6. Warnings will be issued when they are used.
    • QA Risk Assessment:
      Needs Assessment

      Description

      Ruby 2.1 is EOL. Ruby 2.2 went EOL on March 18, 2018. We need to bump the Puppet::OLDEST_RECOMMENDED_RUBY_VERSION to 2.3 in preparation for Puppet 6.

        Attachments

          Activity

            People

            • Assignee:
              patrick Patrick Carlisle
              Reporter:
              josh Josh Cooper
            • Votes:
              0 Vote for this issue
              Watchers:
              1 Start watching this issue

              Dates

              • Created:
                Updated:
                Resolved:

                Zendesk Support