Uploaded image for project: 'Puppet'
  1. Puppet
  2. PUP-8609

Bump FFI gem to ~> 1.9.22 to support Ruby 2.5

    Details

    • Type: Task
    • Status: Closed
    • Priority: Normal
    • Resolution: Fixed
    • Affects Version/s: PUP 5.5.0
    • Fix Version/s: PUP 6.0.0
    • Component/s: Windows
    • Labels:
    • Template:
    • Epic Link:
    • Team:
      Platform OS
    • QA Risk Assessment:
      Needs Assessment

      Description

      The pinning of FFI to 1.9.18 done in PUP-8438 is slightly problematic as it means that Puppet cannot be run on Ruby 2.5. This is also causing some issues coordinating FFI versions with PDK and the ubergems like https://rubygems.org/gems/puppet-module-win-default-r2.4

       

      There was initially some concern over the new gems as described in https://github.com/puppetlabs/puppet/commit/d10b21f09107846d03fd8e2df6128f967207366c

       

      This ticket should validate the latest FFI, pick a minimum version, and bump the version in puppet-agent in addition to Puppet repo itself.

        Attachments

          Issue Links

            Activity

              jsd-sla-details-panel

                People

                • Assignee:
                  Unassigned
                  Reporter:
                  ethan Ethan Brown
                • Votes:
                  0 Vote for this issue
                  Watchers:
                  4 Start watching this issue

                  Dates

                  • Created:
                    Updated:
                    Resolved: