Uploaded image for project: 'Puppet'
  1. Puppet
  2. PUP-8616

puppet module upgrade crashes

    XMLWordPrintable

Details

    • Bug
    • Status: Closed
    • Normal
    • Resolution: Incomplete
    • PUP 5.4.0
    • None
    • Modules
    • None
    • Puppet 5.4.0

    • Puppet Developer Experience
    • Needs Assessment
    • Needs Assessment

    Description

      When upgrading a module on a private Forge the client crashes:

      $ puppet module upgrade --module_repository=http://<customer>...com google-gstorage
      Notice: Preparing to upgrade 'google-gstorage' ...
      Notice: Found 'google-gstorage' (v0.2.0) in /home/nelsona/.puppetlabs/etc/code/modules ...
      Error: undefined method `gsub' for false:FalseClass
      /home/nelsona/.rbenv/versions/2.5.0/lib/ruby/gems/2.5.0/gems/puppet-5.4.0/lib/puppet/forge.rb:240:in `decode_uri'
      /home/nelsona/.rbenv/versions/2.5.0/lib/ruby/gems/2.5.0/gems/puppet-5.4.0/lib/puppet/forge.rb:110:in `fetch'
      /home/nelsona/.rbenv/versions/2.5.0/lib/ruby/gems/2.5.0/gems/puppet-5.4.0/lib/puppet/module_tool/applications/upgrader.rb:93:in `run'
      /home/nelsona/.rbenv/versions/2.5.0/lib/ruby/gems/2.5.0/gems/puppet-5.4.0/lib/puppet/face/module/upgrade.rb:73:in `block (3 levels) in <top (required)>'
      /home/nelsona/.rbenv/versions/2.5.0/lib/ruby/gems/2.5.0/gems/puppet-5.4.0/lib/puppet/interface/action.rb+eval[wrapper]:264:in `upgrade'
      /home/nelsona/.rbenv/versions/2.5.0/lib/ruby/gems/2.5.0/gems/puppet-5.4.0/lib/puppet/application/face_base.rb:247:in `main'
      /home/nelsona/.rbenv/versions/2.5.0/lib/ruby/gems/2.5.0/gems/puppet-5.4.0/lib/puppet/application.rb:383:in `run_command'
      /home/nelsona/.rbenv/versions/2.5.0/lib/ruby/gems/2.5.0/gems/puppet-5.4.0/lib/puppet/application.rb:375:in `block in run'
      /home/nelsona/.rbenv/versions/2.5.0/lib/ruby/gems/2.5.0/gems/puppet-5.4.0/lib/puppet/util.rb:665:in `exit_on_fail'
      /home/nelsona/.rbenv/versions/2.5.0/lib/ruby/gems/2.5.0/gems/puppet-5.4.0/lib/puppet/application.rb:375:in `run'
      /home/nelsona/.rbenv/versions/2.5.0/lib/ruby/gems/2.5.0/gems/puppet-5.4.0/lib/puppet/util/command_line.rb:137:in `run'
      /home/nelsona/.rbenv/versions/2.5.0/lib/ruby/gems/2.5.0/gems/puppet-5.4.0/lib/puppet/util/command_line.rb:73:in `execute'
      /home/nelsona/.rbenv/versions/2.5.0/lib/ruby/gems/2.5.0/gems/puppet-5.4.0/bin/puppet:5:in `<top (required)>'
      /home/nelsona/.rbenv/versions/2.5.0/bin/puppet:23:in `load'
      /home/nelsona/.rbenv/versions/2.5.0/bin/puppet:23:in `<main>'

      Attachments

        Issue Links

          Activity

            People

              Unassigned Unassigned
              nelsonjr Nelson Araujo
              Votes:
              0 Vote for this issue
              Watchers:
              3 Start watching this issue

              Dates

                Created:
                Updated:
                Resolved:

                Zendesk Support